diff app/build.gradle @ 454:7492d2cb7b75

update to latest toolchain, gradle 4.10.2
author Carl Byington <carl@five-ten-sg.com>
date Wed, 07 Nov 2018 17:13:10 -0800
parents 2907c688955e
children b00031b2d6ac
line wrap: on
line diff
--- a/app/build.gradle	Mon Mar 21 09:50:22 2016 -0700
+++ b/app/build.gradle	Wed Nov 07 17:13:10 2018 -0800
@@ -19,70 +19,71 @@
 }
 
 
-apply plugin: 'com.android.model.application'
+apply plugin: 'com.android.application'
 
-model {
-    android {
-        compileSdkVersion = 16
-        buildToolsVersion = "23.0.2"
-        buildTypes {
-            release {
-                minifyEnabled = false
-                signingConfig = $("android.signingConfigs.release")
-            }
-            debug {
-                debuggable = true
-                ndk {
-                    debuggable = true
-                }
-            }
-        }
-        productFlavors {
-            create("arm") {
-                ndk.abiFilters.add("armeabi")
-            }
-            create("x86") {
-                ndk.abiFilters.add("x86")
-            }
-        }
-        ndk {
-            moduleName = "com_google_ase_Exec"
-            cppFlags.add("-Werror")
-            ldLibs.add("log")
-        }
-        sources {
-            main {
-                jni {
-                    source {
-                        srcDir "Exec"
-                    }
-                }
-            }
-        }
-        defaultConfig.with {
-            applicationId = "com.five_ten_sg.connectbot"
-            minSdkVersion.apiLevel = 8
-            targetSdkVersion.apiLevel = 15
-        }
-    }
-
-    android.signingConfigs {
-        create("release") {
-            def console = System.console()
-            if (console) {
-                storePassword = new String(console.readPassword("\nkey store password: "))
-                keyPassword   = new String(console.readPassword("\nkey alias password: "))
-            }
-            else {
-                def read = System.in.newReader().&readLine
-                print "\nkey store password"
-                storePassword = read()
-                print "\nkey alias password"
-                keyPassword   = read()
-            }
+android {
+    signingConfigs {
+        release {
+            print "\nNo Console\n"
+            def read = System.in.newReader().&readLine
+            print "\nkey store password"
+            storePassword = read()
+            print "\nkey alias password"
+            keyPassword   = read()
+            print "\nDone\n"
             storeFile = file("../510Connectbot.keystore")
             storeType = "jks"
             keyAlias  = "510Connectbot"
         }
     }
+    compileSdkVersion = 16
+    buildTypes {
+        release {
+            minifyEnabled = false
+            signingConfig = signingConfigs.release
+            ndk {
+                debuggable = false
+                abiFilters 'armeabi-v7a'
+            }
+        }
+        debug {
+            debuggable = true
+            ndk {
+                debuggable = true
+                abiFilters 'armeabi-v7a'
+            }
+        }
+    }
+    flavorDimensions "arch"
+    productFlavors {
+        arm {
+            dimension "arch"
+        }
+        x86 {
+            dimension "arch"
+        }
+    }
+    sourceSets {
+        main {
+            jni {
+                srcDir "Exec"
+            }
+        }
+    }
+
+    defaultConfig {
+        applicationId = "com.five_ten_sg.connectbot"
+        minSdkVersion = 8
+        targetSdkVersion = 15
+        ndk {
+            moduleName = "com_google_ase_Exec"
+        }
+    }
+
+    externalNativeBuild {
+        ndkBuild {
+            path "src/main/jni/Android.mk"
+        }
+    }
+
 }