diff Makefile.am @ 108:1c7677042b78

move to autoconf/automake/docbook
author carl
date Sun, 18 Dec 2005 12:05:05 -0800
parents c3e9fa6b37c6
children d0dad5610980
line wrap: on
line diff
--- a/Makefile.am	Sun Dec 18 09:50:25 2005 -0800
+++ b/Makefile.am	Sun Dec 18 12:05:05 2005 -0800
@@ -1,21 +1,20 @@
 SUBDIRS = src man html info
 hackdir = $(sysconfdir)
-hack_SCRIPTS = syslog2iptables
-sysconf_DATA = syslog2iptables.conf
-CLEANFILES = syslog2iptables xml/syslog2iptables xml/Makefile
-EXTRA_DIST = syslog2iptables.rc syslog2iptables.conf syslog2iptables.spec $(wildcard xml/h*) $(wildcard xml/M*) $(wildcard xml/s*)
+hack_SCRIPTS = dnsbl
+dconfdir = $(sysconfdir)/dnsbl
+dconf_DATA = dnsbl.conf hosts-ignore.conf html-tags.conf tld.conf
+CLEANFILES = dnsbl xml/dnsbl xml/Makefile
+EXTRA_DIST = dnsbl.rc $(dconf_DATA) dnsbl.spec $(wildcard xml/h*) $(wildcard xml/M*) $(wildcard xml/s*)
 
-syslog2iptables: $(srcdir)/syslog2iptables.rc
-	   rm -f syslog2iptables
-	   echo "#!" $(BASH) >syslog2iptables
-	   cat $(srcdir)/syslog2iptables.rc     | \
+dnsbl: $(srcdir)/dnsbl.rc
+	   rm -f dnsbl
+	   echo "#!" $(BASH) >dnsbl
+	   cat $(srcdir)/dnsbl.rc     | \
 	       sed -e "s,SBINDIR,$(sbindir),g"  | \
-	       sed -e "s,SYSCONFDIR,$(sysconfdir),g" >>syslog2iptables
+	       sed -e "s,SYSCONFDIR,$(sysconfdir),g" >>dnsbl
 
-chkconfig: syslog2iptables
-	   mv -f $(sysconfdir)/syslog2iptables /etc/rc.d/init.d
-	   /sbin/chkconfig --del syslog2iptables
-	   /sbin/chkconfig --add syslog2iptables
-	   /sbin/chkconfig --level 2345 syslog2iptables on
-	   /etc/rc.d/init.d/syslog2iptables start
+chkconfig: dnsbl
+	   mv -f $(sysconfdir)/dnsbl /etc/rc.d/init.d
+	   /sbin/chkconfig --del dnsbl
+	   /sbin/chkconfig --add dnsbl