diff Makefile.am @ 370:5380552644e2

RHEL7 systemd and /var/run on tmpfs
author Carl Byington <carl@five-ten-sg.com>
date Tue, 07 Feb 2017 18:09:52 -0800
parents f92f24950bd3
children 7361afe0df4f
line wrap: on
line diff
--- a/Makefile.am	Tue Jan 17 14:13:41 2017 -0800
+++ b/Makefile.am	Tue Feb 07 18:09:52 2017 -0800
@@ -2,18 +2,23 @@
 
 SUBDIRS = src man html info
 hackdir = $(sysconfdir)/dnsbl
-hack_SCRIPTS = dnsbl
+hack_SCRIPTS = dnsbl dnsbl.service dnsbl-tmpfs.conf
 hack_DATA = dnsbl.conf hosts-ignore.conf html-tags.conf tld.conf dnsblnogrey
 htmldir = ${datadir}/doc/@PACKAGE@-@VERSION@
 html_DATA = AUTHORS COPYING ChangeLog NEWS README
-CLEANFILES = dnsbl xml/dnsbl xml/Makefile
-EXTRA_DIST = $(hack_DATA) dnsbl.spec make-tld-conf.py xml/header.sgml xml/header.xml xml/Makefile.am xml/Makefile.in xml/dnsbl.in
+CLEANFILES = dnsbl dnsbl.service dnsbl-tmpfs.conf xml/dnsbl xml/Makefile
+EXTRA_DIST = dnsbl-tmpfs.conf dnsbl.rc dnsbl.service.rc $(hack_DATA) dnsbl.spec make-tld-conf.py xml/header.sgml xml/header.xml xml/Makefile.am xml/Makefile.in xml/dnsbl.in
 
 dnsbl: dnsbl.rc
 	   cat dnsbl.rc                         | \
 	       sed -e "s,SBINDIR,$(sbindir),g"  | \
 	       sed -e "s,SYSCONFDIR,$(sysconfdir),g" >dnsbl
 
+dnsbl.service: dnsbl.service.rc
+	   cat dnsbl.service.rc                 | \
+	       sed -e "s,SBINDIR,$(sbindir),g"  | \
+	       sed -e "s,SYSCONFDIR,$(sysconfdir),g" >dnsbl.service
+
 chkconfig: dnsbl
 	   /usr/bin/getent passwd dnsbl >/dev/null || /usr/sbin/useradd -r -d $(sysconfdir)/dnsbl -M -c "dnsbl pseudo-user" -s /sbin/nologin dnsbl >/dev/null
 	   mv -f $(sysconfdir)/dnsbl/dnsbl /etc/rc.d/init.d