diff configure.in @ 148:9330b8d6a56b

add documentation fixes, allow env_from target of inherit
author carl
date Tue, 30 Jan 2007 16:27:49 -0800
parents 812c80305f26
children 9581f6e62574
line wrap: on
line diff
--- a/configure.in	Mon Dec 04 21:49:09 2006 -0800
+++ b/configure.in	Tue Jan 30 16:27:49 2007 -0800
@@ -1,20 +1,45 @@
-AC_INIT(configure.in)
 
-AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(dnsbl,5.26)
+AC_PREREQ(2.59)
+AC_INIT(dnsbl,5.27,carl@five-ten-sg.com)
+AC_CONFIG_SRCDIR([config.h.in])
+AC_CONFIG_HEADER([config.h])
+
+AM_INIT_AUTOMAKE($PACKAGE_NAME,$PACKAGE_VERSION)
+
+# Checks for programs.
 AC_PATH_PROGS(BASH, bash)
+AC_PROG_CXX
+AC_PROG_CC
+AC_PROG_CPP
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
+AC_PROG_RANLIB
 
-AC_LANG_CPLUSPLUS
-AC_PROG_CXX
-AC_PROG_LIBTOOL
+# Checks for header files.
+AC_HEADER_SYS_WAIT
+AC_CHECK_HEADERS([arpa/inet.h netdb.h netinet/in.h sys/ioctl.h sys/socket.h syslog.h unistd.h])
 
-AC_OUTPUT(                  \
-    Makefile                \
-    dnsbl.spec              \
-    html/Makefile           \
-    info/Makefile           \
-    man/Makefile            \
-    src/Makefile            \
-    xml/Makefile            \
-    xml/dnsbl               \
-    )
+# Checks for typedefs, structures, and compiler characteristics.
+AC_HEADER_STDBOOL
+AC_C_CONST
+AC_TYPE_PID_T
+AC_TYPE_SIZE_T
+
+# Checks for library functions.
+AC_FUNC_ERROR_AT_LINE
+AC_FUNC_FORK
+AC_FUNC_GETPGRP
+AC_HEADER_STDC
+AC_FUNC_STAT
+AC_CHECK_FUNCS([gethostbyname gethostname memmove memset socket strchr strdup strncasecmp strrchr strstr strtol])
+
+AC_CONFIG_FILES([Makefile
+                 dnsbl.spec
+                 html/Makefile
+                 info/Makefile
+                 man/Makefile
+                 src/Makefile
+                 xml/Makefile
+                 xml/dnsbl])
+AC_OUTPUT