diff Makefile.am @ 112:96b2eb7f25f5

move to autoconf/automake/docbook
author carl
date Sun, 18 Dec 2005 16:56:38 -0800
parents d0dad5610980
children 0094678a16d0
line wrap: on
line diff
--- a/Makefile.am	Sun Dec 18 15:16:25 2005 -0800
+++ b/Makefile.am	Sun Dec 18 16:56:38 2005 -0800
@@ -1,10 +1,9 @@
 SUBDIRS = src man html info
-hackdir = $(sysconfdir)
+hackdir = $(sysconfdir)/dnsbl
 hack_SCRIPTS = dnsbl
-dconfdir = $(sysconfdir)/dnsbl
-dconf_DATA = dnsbl.conf hosts-ignore.conf html-tags.conf tld.conf
+hack_DATA = dnsbl.conf hosts-ignore.conf html-tags.conf tld.conf
 CLEANFILES = dnsbl xml/dnsbl xml/Makefile
-EXTRA_DIST = dnsbl.rc $(dconf_DATA) dnsbl.spec $(wildcard xml/h*) $(wildcard xml/M*) $(wildcard xml/d*)
+EXTRA_DIST = dnsbl.rc $(hack_DATA) dnsbl.spec $(wildcard xml/h*) $(wildcard xml/M*) $(wildcard xml/d*)
 
 dnsbl: $(srcdir)/dnsbl.rc
 	   rm -f dnsbl
@@ -14,7 +13,7 @@
 	       sed -e "s,SYSCONFDIR,$(sysconfdir),g" >>dnsbl
 
 chkconfig: dnsbl
-	   mv -f $(sysconfdir)/dnsbl /etc/rc.d/init.d
+	   mv -f $(sysconfdir)/dnsbl/dnsbl /etc/rc.d/init.d
 	   /sbin/chkconfig --del dnsbl
 	   /sbin/chkconfig --add dnsbl