diff configure.in @ 167:9b129ed78d7d stable-6-0-6

actually use spamassassin result, allow build without spam assassin, only call it if some recipient needs it.
author carl
date Mon, 27 Aug 2007 20:49:19 -0700
parents bf828f785407
children 6bac960af6b4
line wrap: on
line diff
--- a/configure.in	Sun Aug 26 20:54:59 2007 -0700
+++ b/configure.in	Mon Aug 27 20:49:19 2007 -0700
@@ -1,6 +1,6 @@
 
 AC_PREREQ(2.59)
-AC_INIT(dnsbl,6.05,carl@five-ten-sg.com)
+AC_INIT(dnsbl,6.06,carl@five-ten-sg.com)
 AC_CONFIG_SRCDIR([config.h.in])
 AC_CONFIG_HEADER([config.h])
 
@@ -8,7 +8,13 @@
 
 # Checks for programs.
 AC_PATH_PROG(BASH, bash)
+if test "x$BASH" = x ; then
+   AC_MSG_ERROR([bash required for init script])
+fi
 AC_PATH_PROG(SPAMC, spamc)
+if test "x$SPAMC" = x ; then
+   AC_MSG_WARN([Spamc not found.  SpamAssassin filtering disabled])
+fi
 AC_PROG_CXX
 AC_PROG_CC
 AC_PROG_CPP