diff configure.in @ 242:d8ee4c97b9ab stable-6-0-26

64 bit fixes for libresolv.a
author Carl Byington <carl@five-ten-sg.com>
date Fri, 19 Nov 2010 13:01:07 -0800
parents c0d2e99c0a1d
children ef97c7cd4a6e
line wrap: on
line diff
--- a/configure.in	Fri Nov 19 10:34:33 2010 -0800
+++ b/configure.in	Fri Nov 19 13:01:07 2010 -0800
@@ -1,6 +1,6 @@
 
 AC_PREREQ(2.59)
-AC_INIT(dnsbl,6.25,carl@five-ten-sg.com)
+AC_INIT(dnsbl,6.26,carl@five-ten-sg.com)
 AC_CONFIG_SRCDIR([config.h.in])
 AC_CONFIG_HEADER([config.h])
 
@@ -52,6 +52,22 @@
 # check for posix threads
 ACX_PTHREAD
 
+# find proper libresolv.a location
+AC_MSG_CHECKING([for libresolv.a])
+if test -e /usr/lib64/libresolv.a; then
+    libresolvdir=/usr/lib64
+    libresolvok=yes
+else
+    if test -e /usr/lib/libresolv.a; then
+        libresolvdir=/usr/lib
+        libresolvok=yes
+    else
+        libresolvok=no
+    fi
+fi
+AC_MSG_RESULT($libresolvok)
+AC_SUBST(LIBRESOLVDIR, [$libresolvdir])
+
 # See if we have progress callback
 AC_CHECK_LIB([milter],
              [smfi_progress],