diff src/Makefile.am @ 34:07177825c91b

fix signed/unsigned to allow very small pst files with only leaf nodes
author carl
date Thu, 12 Jul 2007 14:59:13 -0700
parents e5418051878c
children f6db1f060a95
line wrap: on
line diff
--- a/src/Makefile.am	Tue Jul 10 20:23:55 2007 -0700
+++ b/src/Makefile.am	Thu Jul 12 14:59:13 2007 -0700
@@ -1,10 +1,17 @@
 hfiles = $(wildcard *.h)
-bin_PROGRAMS = lspst readpst readpstlog pst2ldif
-lspst_SOURCES      = $(hfiles) debug.c libpst.c libstrfunc.c lspst.c timeconv.c
-readpst_SOURCES    = $(hfiles) readpst.c libpst.c timeconv.c libstrfunc.c debug.c lzfu.c
-readpstlog_SOURCES = $(hfiles) readpstlog.c debug.c
-pst2ldif_SOURCES   = $(hfiles) pst2ldif.cpp libpst.c timeconv.c libstrfunc.c debug.c lzfu.c
-EXTRA_DIST = dumpblocks.c getidblock.c testdebug.c
+bin_PROGRAMS        = lspst readpst readpstlog pst2ldif
+noinst_PROGRAMS     = deltasearch dumpblocks getidblock
+
+lspst_SOURCES       = $(hfiles) debug.c libpst.c libstrfunc.c lspst.c timeconv.c
+readpst_SOURCES     = $(hfiles) readpst.c libpst.c timeconv.c libstrfunc.c debug.c lzfu.c
+readpstlog_SOURCES  = $(hfiles) readpstlog.c debug.c
+pst2ldif_SOURCES    = $(hfiles) pst2ldif.cpp libpst.c timeconv.c libstrfunc.c debug.c lzfu.c
+
+deltasearch_SOURCES = deltasearch.cpp debug.c
+dumpblocks_SOURCES  = dumpblocks.c    debug.c libpst.c libstrfunc.c timeconv.c
+getidblock_SOURCES  = getidblock.c    debug.c libpst.c libstrfunc.c timeconv.c
+
+EXTRA_DIST = testdebug.c
 
 # set the include path found by configure
 INCLUDES= $(all_includes)
@@ -16,7 +23,7 @@
 pst2ldif_LDFLAGS   = $(all_libraries)
 
 # default compile flags
-lspst_CXXFLAGS      =
-readpst_CXXFLAGS    =
-readpstlog_CXXFLAGS =
-pst2ldif_CXXFLAGS   =
+# lspst_CXXFLAGS      =
+# readpst_CXXFLAGS    =
+# readpstlog_CXXFLAGS =
+# pst2ldif_CXXFLAGS   =