diff configure.in @ 326:1e39dc490627 stable-0-6-59

add autoconf checking for libgsf
author Carl Byington <carl@five-ten-sg.com>
date Fri, 17 May 2013 14:09:35 -0700
parents cb67b335afcc
children c507af52515a
line wrap: on
line diff
--- a/configure.in	Fri Jan 18 08:05:08 2013 -0800
+++ b/configure.in	Fri May 17 14:09:35 2013 -0700
@@ -1,5 +1,5 @@
 AC_PREREQ(2.59)
-AC_INIT(libpst,0.6.58,carl@five-ten-sg.com)
+AC_INIT(libpst,0.6.59,carl@five-ten-sg.com)
 AC_CONFIG_SRCDIR([src/libpst.c])
 AC_CONFIG_HEADER([config.h])
 AM_INIT_AUTOMAKE
@@ -19,7 +19,7 @@
 #  6. libtool will build libpst.so.x.y.z where the SONAME is libpst.so.x
 #     and x=current-age, y=age, z=revision
 
-libpst_version_info='5:7:1'
+libpst_version_info='5:8:1'
 AC_SUBST(LIBPST_VERSION_INFO, [$libpst_version_info])
 libpst_so_major='4'
 AC_SUBST(LIBPST_SO_MAJOR, [$libpst_so_major])
@@ -43,6 +43,7 @@
 # 0.6.56    libpst.so.4     libpst.so.4.1.6
 # 0.6.57    libpst.so.4     libpst.so.4.1.6
 # 0.6.58    libpst.so.4     libpst.so.4.1.7
+# 0.6.59    libpst.so.4     libpst.so.4.1.8
 
 
 
@@ -360,6 +361,10 @@
 
 gsf_flags="`pkg-config libgsf-1 --cflags`"
 gsf_libs="`pkg-config libgsf-1 --libs`"
+if test "$gsf_flags" = ""; then
+    AC_MSG_ERROR(libgsf not found)
+fi
+
 AC_SUBST(GSF_FLAGS, [$gsf_flags])
 AC_SUBST(GSF_LIBS, [$gsf_libs])