diff configure.in @ 133:2ec889a79e51

patch from Fridrich Strba, some systems need extra library for regex
author Carl Byington <carl@five-ten-sg.com>
date Sat, 07 Feb 2009 07:57:32 -0800
parents 5e4d6faada34
children 16770fc77139
line wrap: on
line diff
--- a/configure.in	Fri Feb 06 20:38:04 2009 -0800
+++ b/configure.in	Sat Feb 07 07:57:32 2009 -0800
@@ -167,6 +167,13 @@
 AC_LANG_POP([C++])
 
 
+AC_CHECK_FUNCS(regexec,,[AC_CHECK_LIB(regex,regexec,
+               [REGEXLIB=-lregex
+                AC_DEFINE(HAVE_REGEXEC,1,[Define to 1 if you have the regexec function.])],
+               [AC_MSG_ERROR([No regex library found])])])
+AC_SUBST(REGEXLIB)
+
+
 # The following lines adds the --enable-pst-debug option to configure:
 #
 # Give the user the choice to enter one of these: