diff configure.in @ 195:320cfcba8058

add python module interface to the shared library for easy scripting. the shared library must never write to stdout or stderr. fix pst_attach_to_mem so the caller does not need to initialize the buffer pointer.
author Carl Byington <carl@five-ten-sg.com>
date Mon, 20 Apr 2009 19:39:26 -0700
parents 4b498fd68464
children ffd1503a7530
line wrap: on
line diff
--- a/configure.in	Fri Apr 17 13:08:31 2009 -0700
+++ b/configure.in	Mon Apr 20 19:39:26 2009 -0700
@@ -1,5 +1,5 @@
 AC_PREREQ(2.59)
-AC_INIT(libpst,0.6.37,carl@five-ten-sg.com)
+AC_INIT(libpst,0.6.38,carl@five-ten-sg.com)
 AC_CONFIG_SRCDIR([src/libpst.c])
 AC_CONFIG_HEADER([config.h])
 AM_INIT_AUTOMAKE
@@ -24,12 +24,22 @@
 libpst_so_major='2'
 AC_SUBST(LIBPST_SO_MAJOR, [$libpst_so_major])
 
+python_libpst_version_info='1:0:0'
+AC_SUBST(PYTHON_LIBPST_VERSION_INFO, [$python_libpst_version_info])
+python_libpst_so_major='2'
+AC_SUBST(PYTHON_LIBPST_SO_MAJOR, [$python_libpst_so_major])
+
 # libpst
-# version    soname         so library name
-# 0.6.35     libpst.so.2    libpst.so.2.0.0
-# 0.6.37     libpst.so.2    libpst.so.2.1.0
+# version   soname          so library name     python          python library name
+# 0.6.35    libpst.so.2     libpst.so.2.0.0
+# 0.6.37    libpst.so.2     libpst.so.2.1.0
+# 0.6.38    libpst.so.2     libpst.so.2.1.0     _libpst.so.1    _libpst.so.1.0.0
 
 
+# check for boost
+AX_PYTHON
+AX_BOOST_PYTHON
+
 
 # Check for win32
 AC_MSG_CHECKING([for Win32])
@@ -261,6 +271,7 @@
     man/Makefile            \
     src/Makefile            \
     src/pst2dii.cpp         \
+    python/Makefile         \
     xml/Makefile            \
     xml/libpst              \
     )