diff python/Makefile.am @ 195:320cfcba8058

add python module interface to the shared library for easy scripting. the shared library must never write to stdout or stderr. fix pst_attach_to_mem so the caller does not need to initialize the buffer pointer.
author Carl Byington <carl@five-ten-sg.com>
date Mon, 20 Apr 2009 19:39:26 -0700
parents
children ffd1503a7530
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/python/Makefile.am	Mon Apr 20 19:39:26 2009 -0700
@@ -0,0 +1,13 @@
+if PLATFORM_WIN32
+    NO_UNDEFINED = -no-undefined
+else
+    NO_UNDEFINED =
+endif
+
+lib_LTLIBRARIES     = _libpst.la
+_libpst_la_LDFLAGS  = -module $(NO_UNDEFINED) -version-info @PYTHON_LIBPST_VERSION_INFO@
+_libpst_la_SOURCES  = python-libpst.cpp
+_libpst_la_LIBADD   = -lboost_python ../src/libpst.la
+
+# set the include path found by configure
+INCLUDES= -I$(srcdir)/.. -I$(srcdir)/../src $(all_includes) -I$(PYTHON_INCLUDE_DIR)