diff configure.in @ 201:3850a3b11745

fixes for parallel readpst
author Carl Byington <carl@five-ten-sg.com>
date Sat, 16 May 2009 10:32:26 -0700
parents d360f96f71f6
children 5d0358f94031
line wrap: on
line diff
--- a/configure.in	Wed May 13 20:06:53 2009 -0700
+++ b/configure.in	Sat May 16 10:32:26 2009 -0700
@@ -133,7 +133,7 @@
     )
 AC_HEADER_DIRENT
 AC_HEADER_STDC
-AC_CHECK_HEADERS([ctype.h dirent.h errno.h fcntl.h inttypes.h limits.h regex.h semaphore.h signal.h stdarg.h stdint.h stdio.h stdlib.h string.h sys/param.h sys/stat.h sys/types.h time.h unistd.h wchar.h])
+AC_CHECK_HEADERS([ctype.h dirent.h errno.h fcntl.h inttypes.h limits.h regex.h semaphore.h signal.h stdarg.h stdint.h stdio.h stdlib.h string.h sys/param.h sys/shm.h sys/stat.h sys/types.h time.h unistd.h wchar.h])
 AC_SEARCH_LIBS([sem_init],rt)
 
 
@@ -161,7 +161,7 @@
 fi
 AC_FUNC_STRFTIME
 AC_FUNC_VPRINTF
-AC_CHECK_FUNCS([memchr memmove memset regcomp strcasecmp strncasecmp strchr strdup strerror strpbrk strrchr strstr strtol])
+AC_CHECK_FUNCS([chdir getcwd memchr memmove memset regcomp strcasecmp strncasecmp strchr strdup strerror strpbrk strrchr strstr strtol])
 AM_ICONV
 if test "$am_cv_func_iconv" != "yes"; then
     AC_MSG_ERROR([libpst requires iconv which is missing])
@@ -285,11 +285,13 @@
 	enable_shared="yes"
     # check for boost
     AX_PYTHON
-    AX_BOOST_PYTHON
     if test "$ax_python_bin" = "no"; then
         AC_MSG_ERROR(python binary not found)
     fi
-
+    AX_BOOST_PYTHON
+    if test "$ac_cv_boost_python" = "no"; then
+        AC_MSG_ERROR(boost python not found)
+    fi
     AC_SUBST(PYTHON_VERSION, [$ax_python_bin])
 fi