diff src/Makefile.am @ 132:5e4d6faada34

fix from Fridrich Strba for parallel make
author Carl Byington <carl@five-ten-sg.com>
date Fri, 06 Feb 2009 20:38:04 -0800
parents bdb38b434c0a
children 2ec889a79e51
line wrap: on
line diff
--- a/src/Makefile.am	Thu Feb 05 13:51:10 2009 -0800
+++ b/src/Makefile.am	Fri Feb 06 20:38:04 2009 -0800
@@ -27,6 +27,7 @@
                 timeconv.c      \
                 vbuf.c
 
+
 if NEED_XGETOPT
     common_source += XGetopt.c
 	common_header += XGetopt.h
@@ -37,14 +38,14 @@
 if BUILD_DII
     bin_PROGRAMS   += pst2dii
 endif
-lspst_SOURCES       = lspst.c         $(common_header)
-readpst_SOURCES     = readpst.c       $(common_header)
-readpstlog_SOURCES  = readpstlog.c    $(common_header)
-pst2ldif_SOURCES    = pst2ldif.cpp    $(common_header)
-pst2dii_SOURCES     = pst2dii.cpp     $(common_header)
-deltasearch_SOURCES = deltasearch.cpp $(common_header)
-dumpblocks_SOURCES  = dumpblocks.c    $(common_header)
-getidblock_SOURCES  = getidblock.c    $(common_header)
+lspst_SOURCES       = lspst.c          $(common_header)
+readpst_SOURCES     = readpst.c        $(common_header)
+readpstlog_SOURCES  = readpstlog.c     $(common_header)
+pst2ldif_SOURCES    = pst2ldif.cpp     $(common_header)
+pst2dii_SOURCES     = pst2dii.cpp      $(common_header)
+deltasearch_SOURCES = deltasearch.cpp  $(common_header)
+dumpblocks_SOURCES  = dumpblocks.c     $(common_header)
+getidblock_SOURCES  = getidblock.c     $(common_header)
 
 lspst_CFLAGS        = $(AM_CFLAGS)
 readpst_CFLAGS      = $(AM_CFLAGS)
@@ -55,6 +56,15 @@
 dumpblocks_CFLAGS   = $(AM_CFLAGS)
 getidblock_CFLAGS   = $(AM_CFLAGS)
 
+lspst_DEPENDENCIES        = libpst.la
+readpst_DEPENDENCIES      = libpst.la
+readpstlog_DEPENDENCIES   = libpst.la
+pst2ldif_DEPENDENCIES     = libpst.la
+pst2dii_DEPENDENCIES      = libpst.la
+deltasearch_DEPENDENCIES  = libpst.la
+dumpblocks_DEPENDENCIES   = libpst.la
+getidblock_DEPENDENCIES   = libpst.la
+
 if STATIC_TOOLS
     noinst_LTLIBRARIES    = libpst.la
 else
@@ -90,3 +100,5 @@
 dumpblocks_LDADD  = $(all_libraries) $(PSTLIB) $(ICONVLIB)
 getidblock_LDADD  = $(all_libraries) $(PSTLIB) $(ICONVLIB)
 deltasearch_LDADD = $(all_libraries) $(PSTLIB) $(ICONVLIB)
+
+