diff configure.in @ 120:6395ced2b8b2

disable building pst2dii on cygwin consistent ordering of our include files all system includes protected by ifdef HAVE_ from autoconf
author Carl Byington <carl@five-ten-sg.com>
date Sun, 01 Feb 2009 11:24:22 -0800
parents 0f1492b7fe8b
children 8399ef94c11b
line wrap: on
line diff
--- a/configure.in	Sat Jan 31 12:23:46 2009 -0800
+++ b/configure.in	Sun Feb 01 11:24:22 2009 -0800
@@ -7,12 +7,16 @@
 
 AC_CANONICAL_HOST
 
-# Check for Win32
+# Check for win32 which needs iconv library specified on the link line
 AC_MSG_CHECKING([for Win32])
 case "$host" in
     *-mingw*)
         os_win32=yes
         ;;
+    *cygwin*)
+        os_win32=yes
+        enable_dii=no   # cygwin would find windir/system32/convert, not image magick convert
+        ;;
     *)
         os_win32=no
         ;;
@@ -80,7 +84,7 @@
     )
 AC_HEADER_DIRENT
 AC_HEADER_STDC
-AC_CHECK_HEADERS([fcntl.h inttypes.h limits.h stdint.h stdlib.h string.h sys/param.h unistd.h wchar.h])
+AC_CHECK_HEADERS([ctype.h dirent.h errno.h fcntl.h inttypes.h limits.h signal.h stdarg.h stdint.h stdio.h stdlib.h string.h sys/param.h sys/stat.h sys/types.h time.h unistd.h wchar.h])
 
 # Checks for typedefs, structures, and compiler characteristics.
 AC_HEADER_STDBOOL