diff configure.in @ 172:6954d315aaa8

move version-info into main configure.in, and set it properly. prefix all external symbols in the shared library with pst_ to avoid symbol clashes with other shared libraries.
author Carl Byington <carl@five-ten-sg.com>
date Sat, 04 Apr 2009 16:00:48 -0700
parents 0e1e048716e4
children d9393349ab29
line wrap: on
line diff
--- a/configure.in	Sun Mar 29 08:51:13 2009 -0700
+++ b/configure.in	Sat Apr 04 16:00:48 2009 -0700
@@ -5,6 +5,23 @@
 AM_INIT_AUTOMAKE
 AC_CANONICAL_HOST
 
+#
+#  1. Remember that version-info is current:revision:age, and age <= current.
+#  2. If the source code has changed at all since the last public release,
+#     then increment revision (`c:r:a' becomes `c:r+1:a').
+#  3. If any interfaces have been added, removed, or changed since the last
+#     update, increment current, and set revision to 0.
+#  4. If any interfaces have been added since the last public release, then
+#     increment age, since we should be backward compatible with the previous
+#     version.
+#  5. If any interfaces have been removed or changed since the last public
+#     release, then set age to 0, since we are not backward compatible.
+#  6. libtool will build libpst.so.x.y.z where the SONAME is libpst.so.x
+#     and x=current-age, y=age, z=revision
+
+libpst_version_info='2:0:0'
+AC_SUBST(LIBPST_VERSION_INFO, [$libpst_version_info])
+
 
 # Check for win32
 AC_MSG_CHECKING([for Win32])
@@ -196,7 +213,6 @@
     enable_static_tools=no
 fi
 
-
 # needed by STATIC_TOOLS in src/Makefile.am
 AC_SUBST(PST_OBJDIR, [$objdir])