diff src/Makefile.am @ 172:6954d315aaa8

move version-info into main configure.in, and set it properly. prefix all external symbols in the shared library with pst_ to avoid symbol clashes with other shared libraries.
author Carl Byington <carl@five-ten-sg.com>
date Sat, 04 Apr 2009 16:00:48 -0700
parents 40e9de445038
children 9bbc834d5f3e
line wrap: on
line diff
--- a/src/Makefile.am	Sun Mar 29 08:51:13 2009 -0700
+++ b/src/Makefile.am	Sat Apr 04 16:00:48 2009 -0700
@@ -74,7 +74,7 @@
         libstrfunc.h\
         timeconv.h  \
         vbuf.h
-    libpst_la_LDFLAGS     = $(NO_UNDEFINED) -version-info 1:3:0
+    libpst_la_LDFLAGS     = $(NO_UNDEFINED) -version-info @LIBPST_VERSION_INFO@
 endif
 
 libpst_la_SOURCES     = $(common_source) $(common_header)