diff src/Makefile.am @ 59:7d5c637aaafb

General cleanup and code fixes. Use autoscan to cleanup our autoconf system. Use autoconf to detect when we need to use our XGetopt files and other header files. Decode BCC field. Fix missing LE32_CPU byte swapping for FILETIME types.
author Carl Byington <carl@five-ten-sg.com>
date Thu, 14 Feb 2008 14:55:32 -0800
parents f6db1f060a95
children cfd6175f9334
line wrap: on
line diff
--- a/src/Makefile.am	Wed Feb 06 23:05:56 2008 -0800
+++ b/src/Makefile.am	Thu Feb 14 14:55:32 2008 -0800
@@ -11,6 +11,13 @@
 dumpblocks_SOURCES  = dumpblocks.c    debug.c libpst.c libstrfunc.c timeconv.c vbuf.c generic.c
 getidblock_SOURCES  = getidblock.c    debug.c libpst.c libstrfunc.c timeconv.c vbuf.c generic.c
 
+if NEED_XGETOPT
+    lspst_SOURCES       += XGetopt.c
+    readpst_SOURCES     += XGetopt.c
+    readpstlog_SOURCES  += XGetopt.c
+    pst2ldif_SOURCES    += XGetopt.c
+endif
+
 EXTRA_DIST = testdebug.c
 
 # set the include path found by configure
@@ -22,8 +29,3 @@
 readpstlog_LDFLAGS = $(all_libraries)
 pst2ldif_LDFLAGS   = $(all_libraries)
 
-# default compile flags
-# lspst_CXXFLAGS      =
-# readpst_CXXFLAGS    =
-# readpstlog_CXXFLAGS =
-# pst2ldif_CXXFLAGS   =