diff src/Makefile.am @ 308:97c53c6868ab

add -m option to readpst to create Outlook .msg files
author Carl Byington <carl@five-ten-sg.com>
date Sun, 13 Dec 2009 14:48:20 -0800
parents 2f38c4ce606f
children c4537664ff50
line wrap: on
line diff
--- a/src/Makefile.am	Fri Dec 11 08:57:25 2009 -0800
+++ b/src/Makefile.am	Sun Dec 13 14:48:20 2009 -0800
@@ -37,20 +37,14 @@
     bin_PROGRAMS   += pst2dii
 endif
 lspst_SOURCES       = lspst.c          $(common_header)
-readpst_SOURCES     = readpst.c        $(common_header)
+readpst_SOURCES     = readpst.c        $(common_header) msg.cpp msg.h
 pst2ldif_SOURCES    = pst2ldif.cpp     $(common_header)
 pst2dii_SOURCES     = pst2dii.cpp      $(common_header)
 deltasearch_SOURCES = deltasearch.cpp  $(common_header)
 dumpblocks_SOURCES  = dumpblocks.c     $(common_header)
 getidblock_SOURCES  = getidblock.c     $(common_header)
 
-lspst_CFLAGS        = $(AM_CFLAGS)
-readpst_CFLAGS      = $(AM_CFLAGS)
-pst2ldif_CFLAGS     = $(AM_CFLAGS)
-pst2dii_CFLAGS      = $(AM_CFLAGS)
-deltasearch_CFLAGS  = $(AM_CFLAGS)
-dumpblocks_CFLAGS   = $(AM_CFLAGS)
-getidblock_CFLAGS   = $(AM_CFLAGS)
+readpst_CPPFLAGS    = $(AM_CPPFLAGS) $(GSF_FLAGS)
 
 lspst_DEPENDENCIES        = libpst.la
 readpst_DEPENDENCIES      = libpst.la
@@ -88,7 +82,7 @@
 
 # the library search path.
 lspst_LDADD       = $(all_libraries) $(PSTLIB) $(LTLIBICONV)
-readpst_LDADD     = $(all_libraries) $(PSTLIB) $(LTLIBICONV) $(REGEXLIB)
+readpst_LDADD     = $(all_libraries) $(PSTLIB) $(LTLIBICONV) $(REGEXLIB) $(GSF_LIBS)
 pst2ldif_LDADD    = $(all_libraries) $(PSTLIB) $(LTLIBICONV)
 pst2dii_LDADD     = $(all_libraries) $(PSTLIB) $(LTLIBICONV) -lgd
 dumpblocks_LDADD  = $(all_libraries) $(PSTLIB) $(LTLIBICONV)