diff configure.in @ 75:987aa872294e stable-0-6-11

Use ftello/fseeko to properly handle large files. Document and properly use datasize field in b5 blocks. Fix some MSVC compile issues and collect MSVC dependencies into one place.
author Carl Byington <carl@five-ten-sg.com>
date Tue, 03 Jun 2008 12:00:58 -0700
parents 3cb02cb1e6cd
children 87216aefc6df
line wrap: on
line diff
--- a/configure.in	Thu May 29 18:59:38 2008 -0700
+++ b/configure.in	Tue Jun 03 12:00:58 2008 -0700
@@ -1,5 +1,5 @@
 AC_PREREQ(2.59)
-AC_INIT(libpst,0.6.10,carl@five-ten-sg.com)
+AC_INIT(libpst,0.6.11,carl@five-ten-sg.com)
 AC_CONFIG_SRCDIR([config.h.in])
 AC_CONFIG_HEADER([config.h])
 
@@ -24,6 +24,7 @@
 AC_PROG_RANLIB
 
 AC_SYS_LARGEFILE
+AC_CHECK_SIZEOF(off_t)
 
 # Checks for header files.
 AC_CHECK_HEADER([unistd.h],
@@ -45,6 +46,7 @@
 AC_STRUCT_TM
 
 # Checks for library functions.
+AC_FUNC_FSEEKO
 AC_FUNC_LSTAT
 AC_FUNC_LSTAT_FOLLOWS_SLASHED_SYMLINK
 AC_FUNC_MALLOC