diff configure.in @ 99:b7f456946c5b

add configure option --enable-dii=no to remove dependency on libgd. many fixes in pst2ldif by Robert Harris.
author Carl Byington <carl@five-ten-sg.com>
date Sun, 28 Sep 2008 17:08:52 -0700
parents 2e3ec9511166
children 1e4a7610d525
line wrap: on
line diff
--- a/configure.in	Sun Sep 14 16:06:25 2008 -0700
+++ b/configure.in	Sun Sep 28 17:08:52 2008 -0700
@@ -1,19 +1,41 @@
 AC_PREREQ(2.59)
-AC_INIT(libpst,0.6.19,carl@five-ten-sg.com)
+AC_INIT(libpst,0.6.20,carl@five-ten-sg.com)
 AC_CONFIG_SRCDIR([config.h.in])
 AC_CONFIG_HEADER([config.h])
 
 AM_INIT_AUTOMAKE($PACKAGE_NAME,$PACKAGE_VERSION)
 
+
 # Checks for programs.
 my_build_dii=yes
 AC_PATH_PROG(CONVERT, convert)
 if test "x$CONVERT" = "x" ; then
     AC_MSG_WARN([convert not found.  pst2dii disabled])
     my_build_dii=no
+else
+    # The following lines adds the --enable-dii option to configure:
+    #
+    # Give the user the choice to enter one of these:
+    # --enable-dii
+    # --enable-dii=yes
+    # --enable-dii=no
+    #
+    AC_MSG_CHECKING([whether we are enabling dii utility])
+    AC_ARG_ENABLE(dii,
+          AC_HELP_STRING([--enable-dii], [enable dii utility]),
+          [if test "${enable_dii}" = "no" ; then
+              AC_MSG_RESULT([no])
+              my_build_dii=no
+          else
+              AC_MSG_RESULT([yes])
+          fi],
+          # Default value for configure
+          AC_MSG_RESULT([yes])
+          )
 fi
 AM_CONDITIONAL(BUILD_DII, test $my_build_dii = yes)
 
+
 # Checks for programs.
 AC_PROG_CXX
 AC_PROG_CC
@@ -58,7 +80,12 @@
 AC_CHECK_FUNCS([memchr memmove memset strcasecmp strchr strdup strerror strpbrk strrchr strstr strtol])
 
 # iconv on mac is a library
+SAVELIBS="${LIBS}"
 AC_SEARCH_LIBS([iconv_open], [iconv])
+if test "x${SAVELIBS}" != "x${LIBS}"; then
+    all_libraries="/usr/lib $all_libraries"
+    AC_SUBST(all_libraries)
+fi
 
 # The following lines adds the --enable-pst-debug option to configure:
 #