diff configure.in @ 31:b88ceb81dba2

mege changes from Joe Nahmias
author carl
date Tue, 10 Jul 2007 17:17:28 -0700
parents 51d826f31329
children 07177825c91b
line wrap: on
line diff
--- a/configure.in	Sat Feb 25 16:16:15 2006 -0800
+++ b/configure.in	Tue Jul 10 17:17:28 2007 -0700
@@ -1,13 +1,33 @@
 AC_INIT(configure.in)
 
 AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(libpst,0.5.4)
+AM_INIT_AUTOMAKE(libpst,0.5.5)
 AC_PATH_PROGS(BASH, bash)
 
 AC_LANG_CPLUSPLUS
 AC_PROG_CXX
 AC_PROG_LIBTOOL
 
+# The following lines adds the --enable-pst-debug option to configure:
+#
+# Give the user the choice to enter one of these:
+# --enable-pst-debug
+# --enable-pst-debug=yes
+# --enable-pst-debug=no
+#
+AC_MSG_CHECKING([whether we are enabling pst debug code])
+AC_ARG_ENABLE(pst-debug,
+      AC_HELP_STRING([--enable-pst-debug], [enable pst debug code]),
+      [if test "${enable_pst_debug}" = "no" ; then
+          AC_MSG_RESULT([no])
+      else
+          AC_DEFINE(DEBUG_ALL, 1, Define to 1 to enable pst debug code)
+          AC_MSG_RESULT([yes])
+      fi],
+      # Default value for configure
+      AC_MSG_RESULT([no])
+      )
+
 AC_OUTPUT(                  \
     Makefile                \
     libpst.spec             \