diff configure.in @ 122:bdb38b434c0a

more changes from Fridrich Strba to avoid installing our config.h
author Carl Byington <carl@five-ten-sg.com>
date Mon, 02 Feb 2009 21:55:48 -0800
parents 8399ef94c11b
children ab2a11e72250
line wrap: on
line diff
--- a/configure.in	Sun Feb 01 19:21:47 2009 -0800
+++ b/configure.in	Mon Feb 02 21:55:48 2009 -0800
@@ -13,10 +13,6 @@
     *-mingw*)
         os_win32=yes
         ;;
-    *cygwin*)
-        os_win32=yes
-        enable_dii=no   # cygwin would find windir/system32/convert, not image magick convert
-        ;;
     *)
         os_win32=no
         ;;
@@ -24,6 +20,19 @@
 AC_MSG_RESULT($os_win32)
 AM_CONDITIONAL(OS_WIN32, [test "$os_win32" = "yes"])
 
+# Check for Win32 platform
+AC_MSG_CHECKING([for Win32 platform in general])
+case "$host" in
+    *-cygwin*)
+        platform_win32=yes
+        ;;
+    *)
+        platform_win32=$os_win32
+        ;;
+esac
+AC_MSG_RESULT($platform_win32)
+AM_CONDITIONAL(PLATFORM_WIN32, [test "$platform_win32" = "yes"])
+
 
 # Checks for programs.
 # The following lines adds the --enable-dii option to configure:
@@ -241,7 +250,6 @@
     info/Makefile           \
     libpst.pc               \
     libpst.spec             \
-    libpst/Makefile         \
     man/Makefile            \
     src/Makefile            \
     src/pst2dii.cpp         \