diff configure.in @ 226:bfc35fd55254 stable-0-6-41

fix python autoconf macros
author Carl Byington <carl@five-ten-sg.com>
date Tue, 23 Jun 2009 20:22:42 -0700
parents 9859474779da
children be1009c92ac2
line wrap: on
line diff
--- a/configure.in	Tue Jun 23 16:12:10 2009 -0700
+++ b/configure.in	Tue Jun 23 20:22:42 2009 -0700
@@ -283,11 +283,17 @@
 AM_CONDITIONAL(PYTHON_INTERFACE, [test "$enable_python" = "yes"])
 if test "$enable_python" = "yes"; then
 	enable_shared="yes"
-    # check for boost
+    # get the version of installed python
     AX_PYTHON
     if test "$ax_python_bin" = "no"; then
         AC_MSG_ERROR(python binary not found)
     fi
+    py_ver=`echo $ax_python_bin | cut -c7-`
+    # find the flags for that version
+    AC_PYTHON_DEVEL([$py_ver])
+    PYTHON_INCLUDE_DIR=`echo $python_path | cut -c3-`
+    AC_SUBST([PYTHON_INCLUDE_DIR])
+    # do we have boost python
     AX_BOOST_PYTHON
     if test "$ac_cv_boost_python" = "no"; then
         AC_MSG_ERROR(boost python not found)