diff src/Makefile.am @ 316:c4537664ff50

merge .msg generation code
author Carl Byington <carl@five-ten-sg.com>
date Mon, 24 Dec 2012 17:51:12 -0800
parents 8ad8fd1c5451 97c53c6868ab
children 0ccc746c8079
line wrap: on
line diff
--- a/src/Makefile.am	Mon Dec 24 16:26:39 2012 -0800
+++ b/src/Makefile.am	Mon Dec 24 17:51:12 2012 -0800
@@ -45,7 +45,7 @@
     bin_PROGRAMS   += pst2dii
 endif
 lspst_SOURCES       = lspst.c          $(common_header)
-readpst_SOURCES     = readpst.c        $(common_header)
+readpst_SOURCES     = readpst.c        $(common_header) msg.cpp msg.h
 pst2ldif_SOURCES    = pst2ldif.cpp     $(common_header)
 pst2dii_SOURCES     = pst2dii.cpp      $(common_header)
 deltasearch_SOURCES = deltasearch.cpp  $(common_header)
@@ -53,6 +53,7 @@
 getidblock_SOURCES  = getidblock.c     $(common_header)
 nick2ldif_SOURCES   = nick2ldif.cpp    $(common_header)
 
+readpst_CPPFLAGS    = $(AM_CPPFLAGS) $(GSF_FLAGS)
 
 lspst_DEPENDENCIES        = libpst.la
 readpst_DEPENDENCIES      = libpst.la
@@ -91,7 +92,7 @@
 
 # the library search path.
 lspst_LDADD       = $(all_libraries) $(PSTLIB) $(LTLIBICONV)
-readpst_LDADD     = $(all_libraries) $(PSTLIB) $(LTLIBICONV) $(REGEXLIB)
+readpst_LDADD     = $(all_libraries) $(PSTLIB) $(LTLIBICONV) $(REGEXLIB) $(GSF_LIBS)
 pst2ldif_LDADD    = $(all_libraries) $(PSTLIB) $(LTLIBICONV)
 pst2dii_LDADD     = $(all_libraries) $(PSTLIB) $(LTLIBICONV) -lgd
 deltasearch_LDADD = $(all_libraries) $(PSTLIB) $(LTLIBICONV)