diff configure.in @ 196:ffd1503a7530

build proper python rpm subpackage
author Carl Byington <carl@five-ten-sg.com>
date Wed, 22 Apr 2009 13:52:18 -0700
parents 320cfcba8058
children 7c60d6d1c681
line wrap: on
line diff
--- a/configure.in	Mon Apr 20 19:39:26 2009 -0700
+++ b/configure.in	Wed Apr 22 13:52:18 2009 -0700
@@ -24,21 +24,21 @@
 libpst_so_major='2'
 AC_SUBST(LIBPST_SO_MAJOR, [$libpst_so_major])
 
-python_libpst_version_info='1:0:0'
-AC_SUBST(PYTHON_LIBPST_VERSION_INFO, [$python_libpst_version_info])
-python_libpst_so_major='2'
-AC_SUBST(PYTHON_LIBPST_SO_MAJOR, [$python_libpst_so_major])
-
 # libpst
-# version   soname          so library name     python          python library name
+# version   soname          so library name
 # 0.6.35    libpst.so.2     libpst.so.2.0.0
 # 0.6.37    libpst.so.2     libpst.so.2.1.0
-# 0.6.38    libpst.so.2     libpst.so.2.1.0     _libpst.so.1    _libpst.so.1.0.0
+# 0.6.38    libpst.so.2     libpst.so.2.1.0
 
 
 # check for boost
 AX_PYTHON
 AX_BOOST_PYTHON
+if test "$ax_python_bin" = "no"; then
+    AC_MSG_ERROR(python binary not found)
+fi
+
+AC_SUBST(PYTHON_VERSION, [$ax_python_bin])
 
 
 # Check for win32