diff python/Makefile.am @ 196:ffd1503a7530

build proper python rpm subpackage
author Carl Byington <carl@five-ten-sg.com>
date Wed, 22 Apr 2009 13:52:18 -0700
parents 320cfcba8058
children 7c60d6d1c681
line wrap: on
line diff
--- a/python/Makefile.am	Mon Apr 20 19:39:26 2009 -0700
+++ b/python/Makefile.am	Wed Apr 22 13:52:18 2009 -0700
@@ -4,10 +4,11 @@
     NO_UNDEFINED =
 endif
 
-lib_LTLIBRARIES     = _libpst.la
-_libpst_la_LDFLAGS  = -module $(NO_UNDEFINED) -version-info @PYTHON_LIBPST_VERSION_INFO@
-_libpst_la_SOURCES  = python-libpst.cpp
-_libpst_la_LIBADD   = -lboost_python ../src/libpst.la
+pythonlibdir            = $(libdir)/@PYTHON_VERSION@/site-packages
+pythonlib_LTLIBRARIES   = _libpst.la
+_libpst_la_LDFLAGS      = -module $(NO_UNDEFINED) -avoid-version
+_libpst_la_SOURCES      = python-libpst.cpp
+_libpst_la_LIBADD       = -lboost_python ../src/libpst.la
 
 # set the include path found by configure
 INCLUDES= -I$(srcdir)/.. -I$(srcdir)/../src $(all_includes) -I$(PYTHON_INCLUDE_DIR)