comparison GraphTastic-client.spec @ 14:0e45fe64b10d

work on building from source
author Carl Byington <carl@five-ten-sg.com>
date Wed, 10 Apr 2013 21:24:14 -0700
parents
children 292b6583148a
comparison
equal deleted inserted replaced
13:c0150404962d 14:0e45fe64b10d
1 # prevent brp repack jar files
2 %define __os_install_post %{nil}
3
4 %define _bindir /usr/local/bin
5 %define gtcommit 06a620d011d08bd2c1099c0d0810c053bf105400
6
7 Summary: Plot metrics sent from logstash
8 Name: GraphTastic-client
9 Version: 0.0.0
10 Release: 0%{?dist}
11 License: Apache 2.0
12 Group: System Environment/Daemons
13 URL: https://github.com/NickPadilla/GraphTastic
14 BuildArch: noarch
15 #Source0: https://github.com/NickPadilla/GraphTastic/tar.gz/%{gtcommit} >GraphTastic.tar.gz
16 Source0: GraphTastic.tar.gz
17 BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
18 BuildRequires: java-1.7.0-openjdk
19
20 %description
21
22
23 %prep
24 %setup -q -n GraphTastic-%{gtcommit}
25
26
27 %build
28 cd src/main/java
29 javac com/monstersoftwarellc/graphtastic/rmi/IRmiService.java
30 jar cf graphtastic-client.jar com/monstersoftwarellc/graphtastic/rmi/IRmiService.class
31 unzip -t graphtastic-client.jar
32
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT%{_bindir}
37 install -D -p -m 644 src/main/java/graphtastic-client.jar $RPM_BUILD_ROOT%{_bindir}
38
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43
44 %files
45 %defattr(-,root,root,-)
46 %attr(0755,root,root) %{_bindir}/*
47
48
49
50 %changelog
51 * Wed Apr 10 2013 <carl@five-ten-sg.com> - 0.0.0-0
52 - Initial build.