comparison elasticsearch.spec @ 14:0e45fe64b10d

work on building from source
author Carl Byington <carl@five-ten-sg.com>
date Wed, 10 Apr 2013 21:24:14 -0700
parents
children aa606d801e02
comparison
equal deleted inserted replaced
13:c0150404962d 14:0e45fe64b10d
1 # prevent brp repack jar files
2 %define __os_install_post %{nil}
3
4 %define _bindir /usr/local/bin
5
6 Summary: elasticsearch is a scalable full text search engine
7 Name: elasticsearch
8 Version: 0.20.6
9 Release: 0%{?dist}
10 Group: System Environment/Daemons
11 License: Apache 2.0
12 URL: http://www.elasticsearch.org/
13 BuildArch: noarch
14 #Source0: curl https://nodeload.github.com/elasticsearch/elasticsearch/tar.gz/v%{version} >elasticsearch-%{version}.tar.gz
15 Source0: %{name}-%{version}.tar.gz
16 BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
17 BuildRequires: java-1.7.0-openjdk
18
19 %if "%{?dist}" != ".el6"
20 # el6 does not have maven yet, so we assume it is manually installed
21 # in /usr/local/apache-maven-3.0.5
22 BuildRequires: maven
23 %endif
24
25 %description
26
27
28 %prep
29 %setup -q
30
31
32 %build
33 [ "%{?dist}" == ".el6" ] && export PATH=/usr/local/apache-maven-3.0.5/bin:$PATH
34 mvn -Dmaven.test.skip=true package
35
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -D -p -m 644 target/elasticsearch-%{version}.jar $RPM_BUILD_ROOT%{_bindir}/elasticsearch.jar
40
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45
46 %files
47 %defattr(-,root,root,-)
48 %attr(0755,root,root) %{_bindir}/*
49
50
51
52 %changelog
53 * Wed Apr 10 2013 <carl@five-ten-sg.com> - 0.20.6-0
54 - Initial build.