comparison logstash.spec @ 13:c0150404962d

start working on building from source
author Carl Byington <carl@five-ten-sg.com>
date Sat, 06 Apr 2013 08:48:09 -0700
parents 4899fb1b3eb3
children 0e45fe64b10d
comparison
equal deleted inserted replaced
12:567e51f1f5e7 13:c0150404962d
1 # prevent brp repack jar files 1 # prevent brp repack jar files
2 %define __os_install_post %{nil} 2 %define __os_install_post %{nil}
3 3
4 %define _bindir /usr/local/bin 4 %define _bindir /usr/local/bin
5 %define ES_VERSION 0.20.6
6 %define gtcommit 06a620d011d08bd2c1099c0d0810c053bf105400
5 7
6 Summary: logstash is a tool for managing events and logs. 8 Summary: logstash is a tool for managing events and logs.
7 Name: logstash 9 Name: logstash
8 Version: 1.1.9 10 Version: 1.1.9
9 Release: 0 11 Release: 0
11 Group: System Environment/Daemons 13 Group: System Environment/Daemons
12 URL: http://logstash.net/ 14 URL: http://logstash.net/
13 BuildArch: noarch 15 BuildArch: noarch
14 Source0: https://logstash.objects.dreamhost.com/release/%{name}-%{version}-monolithic.jar 16 Source0: https://logstash.objects.dreamhost.com/release/%{name}-%{version}-monolithic.jar
15 Source1: https://logstash.jira.com/secure/attachment/12610/logstash_index_cleaner.py 17 Source1: https://logstash.jira.com/secure/attachment/12610/logstash_index_cleaner.py
18 #Source2: curl https://nodeload.github.com/logstash/logstash/tar.gz/v1.1.9 >logstash-1.1.9.tar.gz
19 Source2: %{name}-%{version}.tar.gz
20 Source3: %{name}.Makefile
21 #Source4: curl https://nodeload.github.com/elasticsearch/elasticsearch/tar.gz/V%{ES_VERSION}.tar.gz >elasticsearch-%{ES_VERSION}.tar.gz
22 Source4: elasticsearch-%{ES_VERSION}.tar.gz
23 #Source5: https://github.com/NickPadilla/GraphTastic/tar.gz/%{gtcommit} >GraphTastic.tar.gz
24 Source5: GraphTastic.tar.gz
16 Source10: %{name}.rc 25 Source10: %{name}.rc
17 Source11: %{name}.cron 26 Source11: %{name}.cron
18 Source12: %{name}.conf 27 Source12: %{name}.conf
19 Source13: %{name}.sysconfig 28 Source13: %{name}.sysconfig
20 Source20: apache.pattern 29 Source20: apache.pattern
24 Requires(pre): /usr/sbin/useradd 33 Requires(pre): /usr/sbin/useradd
25 Requires(pre): /usr/bin/getent 34 Requires(pre): /usr/bin/getent
26 Requires(postun): /usr/sbin/userdel 35 Requires(postun): /usr/sbin/userdel
27 Requires(post,preun): /sbin/chkconfig 36 Requires(post,preun): /sbin/chkconfig
28 Requires(post,preun): /sbin/service 37 Requires(post,preun): /sbin/service
38 #BuildRequires: maven
29 BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX) 39 BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
30 40
31 41
32 %description 42 %description
33 logstash is a tool for managing events and logs. You can use it to 43 logstash is a tool for managing events and logs. You can use it to
35 searching). Speaking of searching, logstash comes with a web interface 45 searching). Speaking of searching, logstash comes with a web interface
36 for searching and drilling into all of your logs. 46 for searching and drilling into all of your logs.
37 47
38 48
39 %prep 49 %prep
40 true 50 %setup -q -T -b 2
51 mkdir ES
52 cd ES
53 gzip -dc %SOURCE4 | tar -xvvf -
54 cd ..
55 mkdir GT
56 cd GT
57 gzip -dc %SOURCE5 | tar -xvvf -
58 mv GraphTastic-%{gtcommit} GraphTastic
41 59
42 60
43 %build 61 %build
44 true 62 make -f %SOURCE3
45 63
46 64
47 %install 65 %install
66 # for now, ignore the results of the build, and just package the source jar files.
48 rm -rf $RPM_BUILD_ROOT 67 rm -rf $RPM_BUILD_ROOT
49 mkdir -p $RPM_BUILD_ROOT/var/log/%{name} 68 mkdir -p $RPM_BUILD_ROOT/var/log/%{name}
50 install -D -m 750 %SOURCE0 $RPM_BUILD_ROOT/%{_bindir}/%{name}.jar 69 install -D -m 750 %SOURCE0 $RPM_BUILD_ROOT/%{_bindir}/%{name}.jar
51 install -D -m 750 %SOURCE1 $RPM_BUILD_ROOT/%{_bindir}/logstash_index_cleaner.py 70 install -D -m 750 %SOURCE1 $RPM_BUILD_ROOT/%{_bindir}/logstash_index_cleaner.py
52 install -D -m 755 %SOURCE10 $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name} 71 install -D -m 755 %SOURCE10 $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}