diff GraphTastic-client.spec @ 14:0e45fe64b10d

work on building from source
author Carl Byington <carl@five-ten-sg.com>
date Wed, 10 Apr 2013 21:24:14 -0700
parents
children 292b6583148a
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/GraphTastic-client.spec	Wed Apr 10 21:24:14 2013 -0700
@@ -0,0 +1,52 @@
+# prevent brp repack jar files
+%define __os_install_post %{nil}
+
+%define _bindir  /usr/local/bin
+%define gtcommit   06a620d011d08bd2c1099c0d0810c053bf105400
+
+Summary:        Plot metrics sent from logstash
+Name:           GraphTastic-client
+Version:        0.0.0
+Release:        0%{?dist}
+License:        Apache 2.0
+Group:          System Environment/Daemons
+URL:            https://github.com/NickPadilla/GraphTastic
+BuildArch:      noarch
+#Source0:         https://github.com/NickPadilla/GraphTastic/tar.gz/%{gtcommit} >GraphTastic.tar.gz
+Source0:        GraphTastic.tar.gz
+BuildRoot:      %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
+BuildRequires:  java-1.7.0-openjdk
+
+%description
+
+
+%prep
+%setup -q -n GraphTastic-%{gtcommit}
+
+
+%build
+cd src/main/java
+javac com/monstersoftwarellc/graphtastic/rmi/IRmiService.java
+jar cf graphtastic-client.jar  com/monstersoftwarellc/graphtastic/rmi/IRmiService.class
+unzip -t graphtastic-client.jar
+
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_bindir}
+install -D -p -m 644 src/main/java/graphtastic-client.jar $RPM_BUILD_ROOT%{_bindir}
+
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
+%files
+%defattr(-,root,root,-)
+%attr(0755,root,root) %{_bindir}/*
+
+
+
+%changelog
+* Wed Apr 10 2013  <carl@five-ten-sg.com> - 0.0.0-0
+- Initial build.