diff logstash.spec @ 14:0e45fe64b10d

work on building from source
author Carl Byington <carl@five-ten-sg.com>
date Wed, 10 Apr 2013 21:24:14 -0700
parents c0150404962d
children c158cae7cd26
line wrap: on
line diff
--- a/logstash.spec	Sat Apr 06 08:48:09 2013 -0700
+++ b/logstash.spec	Wed Apr 10 21:24:14 2013 -0700
@@ -2,26 +2,21 @@
 %define __os_install_post %{nil}
 
 %define _bindir  /usr/local/bin
-%define ES_VERSION 0.20.6
-%define gtcommit   06a620d011d08bd2c1099c0d0810c053bf105400
 
 Summary:        logstash is a tool for managing events and logs.
 Name:           logstash
 Version:        1.1.9
-Release:        0
+Release:        0%{?dist}
 License:        Apache 2.0
 Group:          System Environment/Daemons
 URL:            http://logstash.net/
 BuildArch:      noarch
 Source0:        https://logstash.objects.dreamhost.com/release/%{name}-%{version}-monolithic.jar
 Source1:        https://logstash.jira.com/secure/attachment/12610/logstash_index_cleaner.py
-#Source2:         curl https://nodeload.github.com/logstash/logstash/tar.gz/v1.1.9 >logstash-1.1.9.tar.gz
+#Source2:         curl https://nodeload.github.com/logstash/logstash/tar.gz/v%{version} >logstash-%{version}.tar.gz
 Source2:        %{name}-%{version}.tar.gz
-Source3:        %{name}.Makefile
-#Source4:         curl https://nodeload.github.com/elasticsearch/elasticsearch/tar.gz/V%{ES_VERSION}.tar.gz >elasticsearch-%{ES_VERSION}.tar.gz
-Source4:        elasticsearch-%{ES_VERSION}.tar.gz
-#Source5:         https://github.com/NickPadilla/GraphTastic/tar.gz/%{gtcommit} >GraphTastic.tar.gz
-Source5:        GraphTastic.tar.gz
+Source3:        http://logstash.objects.dreamhost.com/maxmind/GeoLite-City-2013-01-18.dat.gz
+Source4:        %{name}.Makefile
 Source10:       %{name}.rc
 Source11:       %{name}.cron
 Source12:       %{name}.conf
@@ -29,14 +24,14 @@
 Source20:       apache.pattern
 Source21:       sendmail.pattern
 Source22:       dnsbl.pattern
+BuildRoot:      %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
 Requires:       logrotate httpd java-1.7.0-openjdk python-pip python-argparse python-ordereddict
 Requires(pre):          /usr/sbin/useradd
 Requires(pre):          /usr/bin/getent
 Requires(postun):       /usr/sbin/userdel
 Requires(post,preun):   /sbin/chkconfig
 Requires(post,preun):   /sbin/service
-#BuildRequires:  maven
-BuildRoot:      %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
+BuildRequires:  ragel jruby
 
 
 %description
@@ -48,24 +43,17 @@
 
 %prep
 %setup -q -T -b 2
-mkdir ES
-cd ES
-gzip -dc %SOURCE4 | tar -xvvf -
-cd ..
-mkdir GT
-cd GT
-gzip -dc %SOURCE5 | tar -xvvf -
-mv GraphTastic-%{gtcommit} GraphTastic
 
 
 %build
-make -f %SOURCE3
+gunzip -c %SOURCE3 >GeoLiteCity.dat
+make -f %SOURCE4
 
 
 %install
 # for now, ignore the results of the build, and just package the source jar files.
 rm -rf $RPM_BUILD_ROOT
-mkdir  -p $RPM_BUILD_ROOT/var/log/%{name}
+install -d $RPM_BUILD_ROOT/var/log/%{name}
 install -D -m 750 %SOURCE0   $RPM_BUILD_ROOT/%{_bindir}/%{name}.jar
 install -D -m 750 %SOURCE1   $RPM_BUILD_ROOT/%{_bindir}/logstash_index_cleaner.py
 install -D -m 755 %SOURCE10  $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}