view elasticsearch.spec @ 19:729f36e68da8 unbundled-1.1.9-working

work on building from source
author Carl Byington <carl@five-ten-sg.com>
date Wed, 17 Apr 2013 11:48:04 -0700
parents 2b887e35b5cd
children 1d50b19beda0
line wrap: on
line source

# prevent brp repack jar files
%define __os_install_post %{nil}

%define _bindir  /usr/local/bin/elasticsearch

Summary:        elasticsearch is a scalable full text search engine
Name:           elasticsearch
Version:        0.20.2
Release:        0%{?dist}
Group:          System Environment/Daemons
License:        Apache 2.0
URL:            http://www.elasticsearch.org/
BuildArch:      noarch
#Source0:         curl https://nodeload.github.com/elasticsearch/elasticsearch/tar.gz/v%{version} >elasticsearch-%{version}.tar.gz
Source0:        %{name}-%{version}.tar.gz
BuildRoot:      %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
BuildRequires:  java-1.7.0-openjdk-devel

%if "%{?dist}" != ".el6"
# el6 does not have maven yet, so we assume it is manually installed
# in /usr/local/apache-maven-3.0.5
BuildRequires:  maven
%endif

%description


%prep
%setup -q


%build
[ "%{?dist}" == ".el6" ] && export PATH=/usr/local/apache-maven-3.0.5/bin:$PATH
mvn -Dmaven.test.skip=true clean package


%install
rm -rf $RPM_BUILD_ROOT
mkdir xx
cd xx
tar xfz ../target/releases/%{name}-%{version}.tar.gz
for f in %{name}-%{version}/lib/*.jar; do
    b=$(basename $f)
    install -D -p -m 644 $f $RPM_BUILD_ROOT%{_bindir}/$b
done
for f in elasticsearch jna jts log4j lucene-core lucene-analyzers lucene-highlighter lucene-memory lucene-queries snappy-java spatial4j; do
    mv $RPM_BUILD_ROOT%{_bindir}/$f*.jar $RPM_BUILD_ROOT%{_bindir}/$f.jar
done


%clean
rm -rf $RPM_BUILD_ROOT


%files
%defattr(-,root,root,-)
%attr(0755,root,root) %{_bindir}



%changelog
* Wed Apr 10 2013  <carl@five-ten-sg.com> - 0.20.6-0
- Initial build.