diff configure.in @ 5:ccf40fd3b050

autoconf cleanup from libpst changes
author Carl Byington <carl@five-ten-sg.com>
date Sat, 07 Feb 2009 11:33:07 -0800
parents 48d06780cf77
children
line wrap: on
line diff
--- a/configure.in	Thu Jun 12 17:51:33 2008 -0700
+++ b/configure.in	Sat Feb 07 11:33:07 2009 -0800
@@ -17,6 +17,7 @@
 AC_PROG_AWK
 AC_PROG_INSTALL
 AC_PROG_LN_S
+AC_PROG_LIBTOOL
 AC_PROG_MAKE_SET
 AC_PROG_RANLIB
 
@@ -24,7 +25,7 @@
 
 # Checks for header files.
 AC_HEADER_SYS_WAIT
-AC_CHECK_HEADERS([arpa/inet.h fcntl.h limits.h netdb.h netinet/in.h sys/socket.h syslog.h unistd.h])
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h limits.h netdb.h netinet/in.h regex.h sys/socket.h syslog.h unistd.h])
 
 # Checks for typedefs, structures, and compiler characteristics.
 AC_HEADER_STDBOOL
@@ -37,6 +38,12 @@
 AC_FUNC_STAT
 AC_CHECK_FUNCS([daemon gethostbyname inet_ntoa memchr memmove memset regcomp strdup strtol])
 
+AC_CHECK_FUNCS(regexec,,[AC_CHECK_LIB(regex,regexec,
+               [REGEXLIB=-lregex
+                AC_DEFINE(HAVE_REGEXEC,1,[Define to 1 if you have the regexec function.])],
+               [AC_MSG_ERROR([No regex library found])])])
+AC_SUBST(REGEXLIB)
+
 # check for posix threads
 ACX_PTHREAD