diff configure.in @ 31:601bc0e075e1

gpl3
author carl
date Sun, 09 Sep 2007 10:59:15 -0700
parents 28fec0c67646
children 3eb867c9beb2
line wrap: on
line diff
--- a/configure.in	Sun Feb 12 11:34:37 2006 -0800
+++ b/configure.in	Sun Sep 09 10:59:15 2007 -0700
@@ -1,20 +1,46 @@
-AC_INIT(configure.in)
 
-AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(syslog2iptables,1.3)
+AC_PREREQ(2.59)
+AC_INIT(syslog2iptables,1.6,carl@five-ten-sg.com)
+AC_CONFIG_SRCDIR([config.h.in])
+AC_CONFIG_HEADER([config.h])
+
+AM_INIT_AUTOMAKE($PACKAGE_NAME,$PACKAGE_VERSION)
+
+# Checks for programs.
 AC_PATH_PROGS(BASH, bash)
+AC_PROG_CXX
+AC_PROG_CC
+AC_PROG_CPP
+AC_PROG_AWK
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
+AC_PROG_RANLIB
 
-AC_LANG_CPLUSPLUS
-AC_PROG_CXX
-AM_PROG_LIBTOOL
+# Checks for libraries.
 
-AC_OUTPUT(                  \
-    Makefile                \
-    syslog2iptables.spec    \
-    html/Makefile           \
-    info/Makefile           \
-    man/Makefile            \
-    src/Makefile            \
-    xml/Makefile            \
-    xml/syslog2iptables     \
-    )
+# Checks for header files.
+AC_HEADER_SYS_WAIT
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h limits.h netdb.h netinet/in.h sys/socket.h syslog.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_HEADER_STDBOOL
+AC_C_CONST
+
+# Checks for library functions.
+AC_FUNC_FORK
+AC_FUNC_GETPGRP
+AC_HEADER_STDC
+AC_FUNC_STAT
+AC_CHECK_FUNCS([gethostbyname inet_ntoa memchr memmove memset regcomp strdup strtol])
+
+AC_CONFIG_FILES([Makefile
+                 syslog2iptables.spec
+                 html/Makefile
+                 info/Makefile
+                 man/Makefile
+                 src/Makefile
+                 xml/Makefile
+                 xml/syslog2iptables])
+
+AC_OUTPUT