diff Makefile.am @ 0:0aa1171aebd2 stable-1-0-0

initial version
author Carl Byington <carl@five-ten-sg.com>
date Wed, 15 May 2013 13:15:59 -0700
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/Makefile.am	Wed May 15 13:15:59 2013 -0700
@@ -0,0 +1,21 @@
+ACLOCAL_AMFLAGS = -I m4
+
+SUBDIRS = src man html info
+hackdir = $(sysconfdir)
+hack_SCRIPTS = wflogs-daemon
+sysconf_DATA = wflogs-daemon.conf
+htmldir = ${datadir}/doc/@PACKAGE@-@VERSION@
+html_DATA = AUTHORS COPYING ChangeLog NEWS README
+CLEANFILES = wflogs-daemon xml/wflogs-daemon xml/Makefile
+EXTRA_DIST = wflogs-daemon.conf wflogs-daemon.spec xml/header.sgml xml/header.xml xml/Makefile.am xml/Makefile.in xml/wflogs-daemon.in
+
+wflogs-daemon: wflogs-daemon.rc
+	   cat wflogs-daemon.rc     | \
+	       sed -e "s,SBINDIR,$(sbindir),g"  | \
+	       sed -e "s,SYSCONFDIR,$(sysconfdir),g" >>wflogs-daemon
+
+chkconfig: wflogs-daemon
+	   mv -f $(sysconfdir)/wflogs-daemon /etc/rc.d/init.d
+	   /sbin/chkconfig --del wflogs-daemon
+	   /sbin/chkconfig --add wflogs-daemon
+