diff xml/Makefile.am @ 180:265c7a65b75b

switch back to fully versioned subpackage dependencies add doxygen devel-doc documentation for the shared library
author Carl Byington <carl@five-ten-sg.com>
date Fri, 10 Apr 2009 12:00:46 -0700
parents 1acd3231c3a4
children b65e8d0a088a
line wrap: on
line diff
--- a/xml/Makefile.am	Thu Apr 09 09:01:15 2009 -0700
+++ b/xml/Makefile.am	Fri Apr 10 12:00:46 2009 -0700
@@ -1,10 +1,12 @@
 all: libpst
-	   cat header.xml  libpst >libpst.xml
-	   cat header.sgml libpst >libpst.sgml
-	   rm -f ../html/*html
-	   rm -f ../html/*pdf
-	   xmlto        -o ../man  man   libpst.xml
-	   xmlto        -o ../html xhtml libpst.xml
-	   xmlto        -o ../html pdf   libpst.xml
-	   docbook2texi -o ../info       libpst.sgml
-	   rm -f libpst.xml libpst.sgml
+	cat header.xml	libpst >libpst.xml
+	cat header.sgml libpst >libpst.sgml
+	rm -f ../html/*html
+	rm -f ../html/*pdf
+	rm -rf ../html/devel
+	xmlto		 -o ../man	man	  libpst.xml
+	xmlto		 -o ../html xhtml libpst.xml
+	xmlto		 -o ../html pdf	  libpst.xml
+	docbook2texi -o ../info		  libpst.sgml
+	rm -f libpst.xml libpst.sgml
+	doxygen