diff configure.ac @ 392:54465fca8b9e

Use PKG_CHECK_MODULES to find the gsf-1 library It uses the architecture-prefixed pkg-config binary, so cross-compiling libpst on multi-arch systems works. Fixes: https://bugs.debian.org/838390
author Paul Wise <pabs3@bonedaddy.net>
date Mon, 23 Dec 2019 12:23:22 +0800
parents 5c0ce43c7532
children ffbb5e3f2551
line wrap: on
line diff
--- a/configure.ac	Sat Dec 21 21:25:45 2019 +0800
+++ b/configure.ac	Mon Dec 23 12:23:22 2019 +0800
@@ -371,14 +371,7 @@
 AC_MSG_RESULT([$enable_profiling])
 AM_CONDITIONAL(GPROF_PROFILING, [test "$enable_profiling" = "yes"])
 
-gsf_flags="`pkg-config libgsf-1 --cflags`"
-gsf_libs="`pkg-config libgsf-1 --libs`"
-if test "$gsf_flags" = ""; then
-    AC_MSG_ERROR(libgsf not found)
-fi
-
-AC_SUBST(GSF_FLAGS, [$gsf_flags])
-AC_SUBST(GSF_LIBS, [$gsf_libs])
+PKG_CHECK_MODULES([GSF], [libgsf-1])
 
 PKG_CHECK_MODULES([ZLIB], [zlib])