diff src/Makefile.am @ 392:54465fca8b9e

Use PKG_CHECK_MODULES to find the gsf-1 library It uses the architecture-prefixed pkg-config binary, so cross-compiling libpst on multi-arch systems works. Fixes: https://bugs.debian.org/838390
author Paul Wise <pabs3@bonedaddy.net>
date Mon, 23 Dec 2019 12:23:22 +0800
parents 0ccc746c8079
children ffbb5e3f2551
line wrap: on
line diff
--- a/src/Makefile.am	Sat Dec 21 21:25:45 2019 +0800
+++ b/src/Makefile.am	Mon Dec 23 12:23:22 2019 +0800
@@ -53,7 +53,7 @@
 getidblock_SOURCES  = getidblock.c     $(common_header)
 nick2ldif_SOURCES   = nick2ldif.cpp    $(common_header)
 
-readpst_CPPFLAGS    = $(AM_CPPFLAGS) $(GSF_FLAGS)
+readpst_CPPFLAGS    = $(AM_CPPFLAGS) $(GSF_CFLAGS)
 
 lspst_DEPENDENCIES        = libpst.la
 readpst_DEPENDENCIES      = libpst.la