diff xml/Makefile.am @ 182:b65e8d0a088a

more cleanup on external names in the shared object file
author Carl Byington <carl@five-ten-sg.com>
date Mon, 13 Apr 2009 11:39:33 -0700
parents 265c7a65b75b
children cf3df962f1e5
line wrap: on
line diff
--- a/xml/Makefile.am	Fri Apr 10 13:10:14 2009 -0700
+++ b/xml/Makefile.am	Mon Apr 13 11:39:33 2009 -0700
@@ -1,3 +1,5 @@
+EXTRA_DIST = Doxyfile $(wildcard *.pdf)
+
 all: libpst
 	cat header.xml	libpst >libpst.xml
 	cat header.sgml libpst >libpst.sgml
@@ -7,6 +9,9 @@
 	xmlto		 -o ../man	man	  libpst.xml
 	xmlto		 -o ../html xhtml libpst.xml
 	xmlto		 -o ../html pdf	  libpst.xml
-	docbook2texi -o ../info		  libpst.sgml
 	rm -f libpst.xml libpst.sgml
+	mkdir tmp
+	mkdir tmp/libpst
+	cp ../src/common.h ../src/libpst.h ../src/libstrfunc.h ../src/timeconv.h ../src/vbuf.h tmp/libpst
 	doxygen
+	rm -rf tmp