diff configure.in @ 9:48880e61ce5e

better autoconf, changes for solaris portability
author carl
date Wed, 03 Jan 2007 22:28:27 -0800
parents 45c8592d5d13
children f9e8bbf33a2a
line wrap: on
line diff
--- a/configure.in	Fri Mar 10 12:55:07 2006 -0800
+++ b/configure.in	Wed Jan 03 22:28:27 2007 -0800
@@ -1,20 +1,40 @@
-AC_INIT(configure.in)
+AC_PREREQ(2.59)
+AC_INIT(sm-archive,1.2,carl@five-ten-sg.com)
+AC_CONFIG_SRCDIR([config.h.in])
+AC_CONFIG_HEADER([config.h])
+
+AM_INIT_AUTOMAKE($PACKAGE_NAME,$PACKAGE_VERSION)
 
-AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(sm-archive,1.0)
-AC_PATH_PROGS(BASH, bash)
+# Checks for programs.
+AC_PROG_CXX
+AC_PROG_CC
+AC_PROG_CPP
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
+AC_PROG_RANLIB
 
-AC_LANG_CPLUSPLUS
-AC_PROG_CXX
-AC_PROG_LIBTOOL
+# Checks for header files.
+AC_HEADER_SYS_WAIT
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h netdb.h netinet/in.h sys/ioctl.h sys/socket.h syslog.h unistd.h])
 
-AC_OUTPUT(                  \
-    Makefile                \
-    sm-archive.spec         \
-    html/Makefile           \
-    info/Makefile           \
-    man/Makefile            \
-    src/Makefile            \
-    xml/Makefile            \
-    xml/sm-archive          \
-    )
+# Checks for typedefs, structures, and compiler characteristics.
+AC_HEADER_STDBOOL
+AC_C_CONST
+
+# Checks for library functions.
+AC_FUNC_FORK
+AC_FUNC_GETPGRP
+AC_HEADER_STDC
+AC_FUNC_STAT
+AC_CHECK_FUNCS([memset socket strchr strdup strncasecmp strtol daemon])
+
+AC_CONFIG_FILES([Makefile
+                 sm-archive.spec
+                 html/Makefile
+                 info/Makefile
+                 man/Makefile
+                 src/Makefile
+                 xml/Makefile
+                 xml/sm-archive])
+AC_OUTPUT