diff src/Makefile.am @ 9:48880e61ce5e

better autoconf, changes for solaris portability
author carl
date Wed, 03 Jan 2007 22:28:27 -0800
parents 01268466f0dc
children f9e8bbf33a2a
line wrap: on
line diff
--- a/src/Makefile.am	Fri Mar 10 12:55:07 2006 -0800
+++ b/src/Makefile.am	Wed Jan 03 22:28:27 2007 -0800
@@ -1,12 +1,13 @@
 sbin_PROGRAMS = smarchive
-smarchive_SOURCES = sm-archive.cpp sm-archive.h context.cpp context.h tokenizer.cpp tokenizer.h includes.h
-EXTRA_DIST = test.cpp
+smarchive_SOURCES = sm-archive.cpp sm-archive.h context.cpp context.h tokenizer.cpp tokenizer.h includes.h daemon.h
+EXTRA_DIST = daemon.c test.cpp
 
 # set the include path found by configure
 INCLUDES= $(all_includes)
 
 # the library search path.
-smarchive_LDFLAGS = $(all_libraries) -lmilter -pthread
+smarchive_LDFLAGS = -pthread
+smarchive_LDADD   = $(all_libraries) -lmilter
 
 # default compile flags
 smarchive_CXXFLAGS = -pthread